Data Connector API error
Incident Report for Treasure Data
Resolved
This incident was resolved.
Today's API feature release included internal table schema change for Data Connector job but for a few Data Connector job configurations new table schema did not have enough size to store. From 19:45 - 20:33 PDT Data Connector job submission API endpoint refused to accept such jobs. We changed table schema to fix this problem quickly.
We're really sorry for the inconvenience this problem has caused.
Posted Aug 25, 2016 - 21:05 PDT
Monitoring
We fixed the problem at 20:33 PDT. Please re-submit Data Connector job if you get 5XX from our API endpoint.
Posted Aug 25, 2016 - 20:50 PDT
Identified
We identified the cause and evaluating the fix.
Posted Aug 25, 2016 - 20:37 PDT
Investigating
We're observing API endpoint of Data Connector job issue returns 5XX server error for specific request. We're investigating now.
Posted Aug 25, 2016 - 20:33 PDT