[US Region] Elevated API error rate
Incident Report for Treasure Data
Resolved
The error rate on REST API was elevated from 8:54pm to 9:24pm PT. REST API is now back to operational.
Posted 4 months ago. Mar 04, 2019 - 22:02 PST
Monitoring
We've stopped problematic database queries that was causing higher load on our underlying database. We confirmed that REST API is working normally now.
Posted 4 months ago. Mar 04, 2019 - 21:43 PST
Update
We are continuing to work on a fix for this issue.
Posted 4 months ago. Mar 04, 2019 - 21:29 PST
Identified
We've identified some of heavy database queries are causing higher load on our underlying database. We're on working to deal with the heavy load.
Posted 4 months ago. Mar 04, 2019 - 21:19 PST
Investigating
Starting from 8:58 pm PT, we are observing elevated error rate on our REST API endpoint. We're on investigation about the cause of the issue.
Posted 4 months ago. Mar 04, 2019 - 21:00 PST
This incident affected: US (REST API, Streaming Import REST API).