Elevated API error rate
Incident Report for Treasure Data
Resolved
All systems are operating normally after the previous update. At 20:34 PDT we started observing elevated API error rate caused by backend RDB connection problem. We rolled out a fix to mitigate the impact of connection problem and everything works fine after that. We'll investigate more of the RDB connection problem to prevent the similar problem happens again.
This incident was resolved.
Posted Sep 20, 2016 - 22:27 PDT
Update
Streaming import delay was resolved at 21:25 PDT. We keep monitoring API servers for a while.
Posted Sep 20, 2016 - 21:54 PDT
Monitoring
From 20:34 PDT error rate of API was high and streaming import and td command API call suffered from this incident. We identified the cause and rolled out the fix and API becomes normal at 21:00. We're still observing max 10 minutes of streaming import delay but it's getting resolved quickly. We keep monitoring for a while.
Posted Sep 20, 2016 - 21:22 PDT
Investigating
We're observing elevated API error rate. Now investigating.
Posted Sep 20, 2016 - 21:08 PDT