API Endpoints: Sporadic 503 Errors
Incident Report for Treasure Data
Resolved
AWS has resolved the network connectivity issues. API should be back to normal.

From AWS:
10:12 PM PDT Between 9:10 PM and 10:00 PM PDT we experienced DNS resolution issues within a single Availability Zone in the US-EAST-1 Region. The issue has been resolved and the service is operating normally.
Posted Jul 18, 2014 - 22:20 PDT
Identified
The problem is due to network problem in an availability zone in EC2. We have removed all instances from the impacted availability and continuing to monitor. Will update when AWS has resolved the network problem.

Quoted from AWS Status Page (http://status.aws.amazon.com/):
9:30 PM PDT We are investigating connectivity issues affecting some instances in a single Availability Zone in the US-EAST-1 Region.
9:34 PM PDT We can confirm that we are experiencing DNS resolution issues within a single Availability Zone in the US-EAST-1 Region. We are working to resolve the issue.
Posted Jul 18, 2014 - 22:02 PDT
Investigating
Some of our API servers are returning 503 errors. Imports and API access is still mostly operational, with some occasional errors, we're investigating...
Posted Jul 18, 2014 - 21:57 PDT