[All Regions] Unable to call Workflow API
Incident Report for Treasure Data
Resolved
The cause of this incident was a misconfiguration in the maintenance procedure for AP03, which affected workflow services in regions not subject to maintenance. We apologize for any inconvenience caused.
Posted Mar 22, 2022 - 20:47 PDT
Monitoring
We observed that the Workflow API were unreachable around 2022-03-23 01:53 to 2022-03-23 01:57 UTC. You can find out the accurate downtime per site as the below.

US Region
2022-03-23 01:53:30 ~ 2022-03-23 01:55:42

Tokyo Region
2022-03-23 01:53:30 ~ 2022-03-23 01:56:31

EU Region
2022-03-23 01:53:30 ~ 2022-03-23 01:57:07

Korea Region
2022-03-23 01:53:30 ~ 2022-03-23 01:57:48

Due to it, the scheduled workflow could be delayed to start and direct workflow api call was unable to be called during that time.
Posted Mar 22, 2022 - 20:09 PDT
This incident affected: US (Workflow), Tokyo (Workflow), EU (Workflow), Korea (Workflow), and AP03 (Workflow).