[All Regions] Facebook Connector Outage
Incident Report for Treasure Data
Resolved
We have confirmed that the restrictions placed on our Facebook App have mitigated the impact on our systems. The root issue is now resolved and we are seeing an increase in successful job completion for affected connectors:
- Facebook Page Insights
- Facebook Ads Reporting
- Facebook Leads
- Facebook Custom Audience
- Instagram Custom Audience
- Instagram Insights
If you have migrated the authentication to use access token temporarily, you might change it back to OAuth.
Posted Jun 03, 2020 - 09:49 PDT
Monitoring
Working with Facebook, we have appealed the restriction placed on our Facebook App. We are seeing this change propagate through the system and jobs should resume to normal operation soon. We are monitoring to confirm that jobs have resumed to normal operation.
Posted Jun 03, 2020 - 09:22 PDT
Update
Our Facebook App is still under restriction and we have submitted a request to Facebook to resolve the issue.

If your failed job is urgent, you might like to retry using a custom Facebook access token. We have prepared a migration document to help you do this:

https://support.treasuredata.com/hc/en-us/articles/360048814814

We will continue to provide updates regarding the restricted Treasure Data Facebook app.
Posted Jun 03, 2020 - 04:20 PDT
Update
Our Facebook App is still under restriction and we have submitted request to Facebook for resolving the issue.
We're also preparing the migration guide for connectors which support access token in order to migrate from Oauth app as a temporary solution.
Posted Jun 03, 2020 - 01:29 PDT
Update
We're still working on resolving the issue. We'll provide an update on the status page once we get any updates.
Posted Jun 02, 2020 - 23:08 PDT
Update
We have identified the problem - TD Facebook OAuth application is disabled unexpectedly & Facebook OAuth connection is not working now.
We are contacting Facebook to appeal the restriction. The jobs which are using access token generated from your own application can still work normally.
The dev team is working on an alternative solution to resolve this issue.
Identified affected connectors:
- Facebook Page Insights
- Facebook Ads Reporting
- Facebook Leads
- Facebook Custom Audience
- Instagram Custom Audience
- Instagram Insights
Posted Jun 02, 2020 - 20:51 PDT
Identified
We have identified the issue. We are continuing to work on a fix for this issue.
Posted Jun 02, 2020 - 19:41 PDT
Investigating
Our Facebook connecters are having an issue. All Facebook related import and export are failing at this time.
Posted Jun 02, 2020 - 19:09 PDT
This incident affected: Tokyo (Data Connector Integrations), EU (Data Connector Integrations), US (Data Connector Integrations), and Korea (Beta) (Data Connector Integrations).