This incident has been resolved, all affected components (Custom Script and some DataConnector) are now back to normal.
Posted Jul 31, 2024 - 00:53 PDT
Monitoring
According to our infrastructure provider (AWS), this issue has already been resolved. We also see that the failure rate has been reduced, so we will update this incident to Monitoring status and the affected components to Operational status.
Posted Jul 30, 2024 - 22:25 PDT
Update
Due to the degradation of Amazon Ads system https://status.ads.amazon.com, our connectors for Amazon Ads platform are currently not working properly. So if you are using any of the below connectors, your jobs may not be running correctly.
We will provide further updates as soon as more information becomes available.
Posted Jul 30, 2024 - 20:16 PDT
Update
This issue is still ongoing, we are still seeing custom script tasks fail. Custom script user may also encounter some errors about AWS Cloud Watch logs.
According to our infrastructure provider (AWS), they are working on recovery and there are some improvements being seen internally, but they expect it to take 1-2 hours for full recovery.
We will provide further updates as soon as more information becomes available.
Posted Jul 30, 2024 - 19:24 PDT
Identified
We are currently experiencing a high error rate in Custom Script service on Treasure Workflow (US Region) due to an ongoing incident with our infrastructure provider (AWS). This issue is increased error rates with the following error message like:
> Task failed with unexpected error: null (Service: AWSLogs; Status Code: 503; Error Code: null; Request ID: xxxxxx; Proxy: null)
At this time, we do not have an estimated time for full resolution. We will provide further updates as soon as more information becomes available.
Posted Jul 30, 2024 - 16:52 PDT
This incident affected: US (Data Connector Integrations).