The scheduled maintenance has been finished, with upgrades to all sites finished.
Posted Nov 25, 2025 - 07:07 PST
Verifying
All sites have been upgraded. We're currently verifying the upgrade and monitoring for regressions.
Posted Nov 25, 2025 - 06:47 PST
Update
All sites except for the environment in Korea have been upgraded, and we're verifying the status and monitoring for regressions.
Posted Nov 25, 2025 - 06:32 PST
Update
Maintenance is still in progress, pending the resource creation by the infrastructure provider, which is taking longer than expected, but is near completion.
Posted Nov 25, 2025 - 06:06 PST
Update
Maintenance is still in progress, pending the resource creation by the infrastructure provider, which is taking longer than expected. We will keep updating this page every 30 minutes.
Posted Nov 25, 2025 - 05:39 PST
Update
Maintenance is still in progress, but the completion is delayed as we await resource creation on our infrastructure provider, which is taking longer than expected.
Posted Nov 25, 2025 - 05:01 PST
Update
Maintenance is still in progress.
Posted Nov 25, 2025 - 04:35 PST
In progress
Scheduled maintenance is currently in progress. We will provide updates every 30 minutes, or as necessary.
Posted Nov 25, 2025 - 04:00 PST
Update
The scheduled maintenance window for the databases supporting PrecisionML will begin in 1h, from 12:00-13:00 UTC, today (November 25th, 2025).
Posted Nov 25, 2025 - 02:57 PST
Scheduled
On November 25th, 2025, from 12:00-13:00 UTC, the databases supporting PrecisionML will undergo a short maintenance period. We'll be upgrading the databases supporting the PrecisionML feature of the Treasure Data Platform. This upgrade is necessary to apply the latest available performance and security patches.
During the maintenance window, customers may experience momentary failures or have PrecisionML runs not created or executed. Any failures will be automatically retried from Treasure Workflow, and no customer action is required to ensure all runs complete.
# Communication
Beyond this notice, we will provide updates approximately 1 hour before the beginning of the maintenance window, at the start and completion of the operation, and once verification is complete. At that time, all systems will have returned to full functionality, and the Scheduled Maintenance will be closed.
If you have any questions or concerns about this maintenance, please feel free to reach out to our Support team at support@treasure-data.com.
Posted Oct 28, 2025 - 10:00 PDT
This scheduled maintenance affected: US (REST API), Tokyo (REST API), EU (REST API), Korea (REST API), and AP03 (REST API).