[ US region ] Audience Studio – Intermittent Query Expired Errors When Retrieving Segment Counts

Incident Report for Treasure Data

Resolved

After a successful monitoring period, we can confirm that our fix is working and the issue is now resolved. Thank you for your patience.
Posted Oct 16, 2025 - 18:55 PDT

Monitoring

We've identified that an internal component between our query engine which extracts the number of records that match Segment rules and Audience Studio ran into a capacity issue during a specific time. We have increased the capacity and will continue to monitor the situation. If the issue does not reoccur by approximately 2025/10/17 01:00 (+00:00), we will consider this incident resolved and close this.
Posted Oct 15, 2025 - 22:05 PDT

Investigating

We are currently investigating an issue where some customers are experiencing intermittent “query expired” errors when retrieving segment counts in Audience Studio. In many cases, queries may succeed after a retry, but this behavior can impact the ability to view or use segment results reliably.

Our engineering teams are actively investigating the root cause and working to mitigate the issue. We will provide updates here as soon as more information becomes available.

In the meantime, affected users may be able to work around the issue by retrying the query after a short interval.
Posted Oct 15, 2025 - 11:16 PDT
This incident affected: US (Web Interface).