[US region] Presto Query Engine - Degraded Performance

Incident Report for Treasure Data

Resolved

The incident is now resolved. All affected components are back to normal.

A subset of customers in the US region might have experienced degraded performance on Presto queries between 4:50 PM EDT and 1:40 AM EDT. Presto queries might also have been queued for longer than usual during the incident. Finally, some queries might have failed due to the remediations that were put in place.
Posted Sep 05, 2024 - 06:18 PDT

Update

Systems should be back to normal but we continue to monitor the situation for a while.
Posted Sep 05, 2024 - 01:28 PDT

Monitoring

We applied the fix. We will continue to monitor the results.
Posted Sep 04, 2024 - 21:44 PDT

Update

Though not all, the performance for some queries has been improved. We are continuing to investigate the issue.
Posted Sep 04, 2024 - 20:53 PDT

Investigating

This incident is still ongoing. We are investigating the root cause.
Posted Sep 04, 2024 - 18:48 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 04, 2024 - 16:19 PDT

Investigating

We are investigating a possible problem currently affecting Presto. Queries could be delayed. We will provide an update as soon as we know more.
Posted Sep 04, 2024 - 15:22 PDT
This incident affected: US (Presto Query Engine).