Sporadic Presto DELETE and INSERT query failures can be observed due to some connection pool issue
Incident Report for Treasure Data
Resolved
This incident has been resolved.
Posted 28 days ago. Aug 21, 2019 - 12:39 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 28 days ago. Aug 21, 2019 - 12:21 PDT
Update
We are continuing to work on a fix for this issue.
Posted 28 days ago. Aug 21, 2019 - 12:02 PDT
Identified
The issue has been identified and a fix is being implemented. The fix requires restarting the Presto Cluster. The Presto Clusters are restarted.
Posted 29 days ago. Aug 21, 2019 - 11:24 PDT
Investigating
The symptom might look like :
com.facebook.presto.spi.PrestoException: Failed to rewrite partition
Killed by the system because this query stalled for more than 1.00h. This is usually caused by a bug of Presto. The query execution will be retried in several minutes.Please ask support@treasure-data.com if you need a further help for this query
Posted 29 days ago. Aug 21, 2019 - 11:23 PDT
This incident affected: US (Presto Query Engine).